Server Upgrades in Progress

Incident Report for Alderon Games

Resolved

Servers are back online
Posted May 21, 2026 - 22:10 UTC

Investigating

Game will be offline while we work on server upgrades
Posted May 21, 2026 - 21:18 UTC
This incident affected: Game API.