Server Issues Loading Character Data

Incident Report for Alderon Games

Resolved

Fixed
Posted Apr 18, 2025 - 20:56 UTC

Investigating

Currently Investigating
Posted Apr 18, 2025 - 20:24 UTC
This incident affected: Game API.