Known Server Issues

Incident Report for Alderon Games

Resolved

Fixed
Posted Dec 20, 2025 - 22:47 UTC

Investigating

Investigating
Posted Dec 20, 2025 - 22:26 UTC
This incident affected: Game API.