Known Issues Server List Loading / Joining

Incident Report for Alderon Games

Resolved

Victory Roar!
Posted May 17, 2026 - 18:26 UTC

Identified

Rolling out a fix in progress
Posted May 17, 2026 - 18:02 UTC
This incident affected: Game API.