Known Server Issues

Incident Report for Alderon Games

Resolved

Fixed
Posted Feb 08, 2026 - 03:51 UTC

Investigating

Players will have issues logging in and playing the game, we are looking into it.
Posted Feb 08, 2026 - 03:38 UTC
This incident affected: Game API and Website.