Server Issues

Incident Report for Alderon Games

Resolved

Fixed
Posted Apr 17, 2025 - 06:09 UTC

Investigating

Currently Investigating
Posted Apr 17, 2025 - 05:01 UTC
This incident affected: Game API.