Matchmaking & Server Issues

Incident Report for Alderon Games

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:43 UTC

Investigating

There is a global Amazon Web Services Outage affecting most games and companies currently. We are looking into it.
Posted Oct 20, 2025 - 11:40 UTC
This incident affected: Game API.