Server Issues

Incident Report for Alderon Games

Resolved

Services are back online!
Posted Apr 14, 2025 - 01:23 UTC

Update

This issue seems to be more technical then expected and related to the game's Database. We are working on a fix, however it may take some time.
Posted Apr 14, 2025 - 00:51 UTC

Investigating

Known Server Issues currently investigating.
Posted Apr 14, 2025 - 00:34 UTC
This incident affected: Game API.